PDA

View Full Version : Bosch K Jettronics Manual



Ricker
07-16-2017, 05:57 PM
Is there a good manual for trouble shooting the fuel injection system? It seems I am always having something not quite right. Now it won't start (well after much cranking) once it sets for a week or so (I drive it on nice weekends only). Once running it is good, until it sets for a week or more.

Thanks for any recommendations on the book!

Ron
07-16-2017, 06:00 PM
Check these out in the Resource Section (http://dmctalk.org/showthread.php?2866-Searchable-Workshop-Technical-Bulletins-and-Volvo-Engine-Manuals).

Bitsyncmaster
07-16-2017, 07:44 PM
It's probably your cold start valve is not working. Mine only needs the CSV after it sits for about one week.

Ricker
07-21-2017, 12:57 PM
It's probably your cold start valve is not working. Mine only needs the CSV after it sits for about one week.

I pulled the CSV (with the engine cold) and hit the starter. It sprayed a nice atomized pattern. But the engine still doesn't want to start properly. It seems like it is still not getting enough gas. It does fires on a few cylinders. After 10 seconds or so it runs fine. Any other direction to check?

Thanks!

Bitsyncmaster
07-21-2017, 04:05 PM
I pulled the CSV (with the engine cold) and hit the starter. It sprayed a nice atomized pattern. But the engine still doesn't want to start properly. It seems like it is still not getting enough gas. It does fires on a few cylinders. After 10 seconds or so it runs fine. Any other direction to check?

Thanks!

Have you checked the mixture setting using a dwell meter? A mixture setting that is pretty far off will have starting problems.

Ricker
07-21-2017, 04:21 PM
Have you checked the mixture setting using a dwell meter? A mixture setting that is pretty far off will have starting problems.

I belong to the Rocky Mountain DeLorean club. We had a past local dealership DeLorean mechanic come in and adjust the mixture with a 4 gas analyzer. I also needed this to get it to pass emissions here in CO. It should be OK?

Bitsyncmaster
07-21-2017, 04:37 PM
I belong to the Rocky Mountain DeLorean club. We had a past local dealership DeLorean mechanic come in and adjust the mixture with a 4 gas analyzer. I also needed this to get it to pass emissions here in CO. It should be OK?

Sounds good. Now lets switch to ignition troubleshooting. You should get 12 volts on the blue/yellow resistor wire when your cranking the engine. Normally I just pull the white resistor wire, start the engine and when you let off the key the engine dies and that proves your "resistor bypass is working".

You can also try bypassing the resistors (just for testing) and see if that gets it started quickly. That would indicate something is week in the ignition circuit.

Ricker
07-22-2017, 11:48 PM
Sounds good. Now lets switch to ignition troubleshooting. You should get 12 volts on the blue/yellow resistor wire when your cranking the engine. Normally I just pull the white resistor wire, start the engine and when you let off the key the engine dies and that proves your "resistor bypass is working".

You can also try bypassing the resistors (just for testing) and see if that gets it started quickly. That would indicate something is week in the ignition circuit.

I turned the key to the on position and got 19 volts between the blue/yellow wire and the engine block. When the starter is on the voltage jumps higher and then back down to the 19 volts. I didn't try disconnecting the white wire cause there are three. Do I try one specific one or all three?

Does the high (19) volts mean something is bad? Also this time the engine started right away but still ran rough for lack of fuel.

Bitsyncmaster
07-23-2017, 06:34 AM
I turned the key to the on position and got 19 volts between the blue/yellow wire and the engine block. When the starter is on the voltage jumps higher and then back down to the 19 volts. I didn't try disconnecting the white wire cause there are three. Do I try one specific one or all three?

Does the high (19) volts mean something is bad? Also this time the engine started right away but still ran rough for lack of fuel.

Something is wrong if you read 19 volts. Maybe your multimeter needs a new battery. A car battery will read 12 to 12.5 volts when the engine is not running. Test your meter reading on another car.

Ricker
07-23-2017, 06:16 PM
Something is wrong if you read 19 volts. Maybe your multimeter needs a new battery. A car battery will read 12 to 12.5 volts when the engine is not running. Test your meter reading on another car.

Ok, so much for that volt meter. - trash. I got a different meter and the battery reads 12.2 volts. The voltage at the blue/yellow wire with the key on is 8.5 volts. With the starter on it goes up to the 12 volts. Again the this time the car started.

Bitsyncmaster
07-23-2017, 08:15 PM
Ok, so much for that volt meter. - trash. I got a different meter and the battery reads 12.2 volts. The voltage at the blue/yellow wire with the key on is 8.5 volts. With the starter on it goes up to the 12 volts. Again the this time the car started.

That sounds about normal.

Matt Carpenter
07-24-2017, 02:44 AM
Is there a good manual for trouble shooting the fuel injection system? It seems I am always having something not quite right. Now it won't start (well after much cranking) once it sets for a week or so (I drive it on nice weekends only). Once running it is good, until it sets for a week or more.

Thanks for any recommendations on the book!

Mine does this as well, occasionally. Following this thread. Thx!


Sent from my iPhone using Tapatalk