Page 6 of 6 FirstFirst ... 4 5 6
Results 51 to 56 of 56

Thread: Unsure of dwell reading

  1. #51
    '82 T3 Turbo FABombjoy's Avatar
    Join Date:  May 2011

    Location:  Lansing, MI

    Posts:    517

    My VIN:    10270

    You can also ground terminal 11 on the k-jet box and send the duty cycle to 90+%.
    WOT switch sets it to ~60%

    I'm not sure how those translate to degrees when using a dwell meter.

    I once tried to measure duty cycle (using an Innovate data logger) using the valve outputs and not the test wire / connector. The readings were about 50% all the time. Once I switched to the proper test connector they started to make more sense.
    Luke S :: 10270 :: 1982 Grey 5-Speed :: Single T3 .60/.48 Watercooled :: Borla Exhaust :: MSD Ignition :: MS3X EFI :: DevilsOwn Methanol Injection

    Console5.com - Game console parts, kits, games and more. [shop] [wiki] [RSS] [f] [t]

  2. #52
    Senior Member Jonathan's Avatar
    Join Date:  Jun 2011

    Location:  Ontario, Canada

    Posts:    3,930

    My VIN:    3937

    Quote Originally Posted by Bitsyncmaster View Post
    Here is a photo of a spare lambda cable I have.

    I would not worry much about the book test to short and use a battery to read specific values of dwell. It's not a real world operation. The O2 sensor is an open circuit when cold and provides a 0.50 volt value at lambda 1.0.

    So if you want to test your ECU, just adjust the mixture lean and rich to read the minimum and maximum dwell values.

    I have never done the short and battery test on the O2 signal. So maybe mine does the same as your seeing.
    I got around to taking some pictures today.

    My wiring on the lambda connector looks about the same as yours does Dave.

    IMG_4548.jpgLambda_connector from Dave on forum.jpg
    One damn minute Admiral...


  3. #53
    Senior Member Jonathan's Avatar
    Join Date:  Jun 2011

    Location:  Ontario, Canada

    Posts:    3,930

    My VIN:    3937

    Just a little update on my own car for this thread.

    You can put me in the "a new O2 sensor made a world of difference" group. I took the car down to the mechanic I used a lot in the first couple years of ownership. Yea, that was on Wednesday, October 21st, 2015 and I thought, what the heck, looks like a good day to get it done.

    He swapped out the sensor without any trouble of snapped threads or seized exhaust fittings and then he also helped me get the mixture adjustment right. He has a lot of experience with K-Jet and Bosch systems and that was a big reason I went to him originally. He showed me the range from stall to stall for the adjustment and it was no more than 12 to 6 o'clock, if we use the hands on the clock analogy again.

    A bit of rain dampered the day on Wednesday, but it was beautiful on the Friday. I got a couple 100 km on the car that day and it drove great. That mechanic said something similar after he took it for a short test drive too. He mentioned how quiet and solid it felt now compared to back in 2007. I've done rear axles and other suspension work since then, but he meant also the interior and that everything just seemed tighter. That was nice to hear as well and a compliment on a lot of other work I've done trying to get that car right.

    Anywho, it was a good day for me and a good day for the car. Cheerio!
    One damn minute Admiral...


  4. #54
    Delorean Guru
    Join Date:  May 2011

    Location:  Northern NJ

    Posts:    6,162

    My VIN:    10757

    Club(s):   (DMA)

    Sounds like he adjusted the mixture by ear. It is too sensitive to do it that way. The better way is to hook up a dwell meter and use the procedure. 1/16 of a turn can make a big difference, 1/2 turn is a LOT! It will have a large effect on your gas mileage, tuning by ear usually results in a richer mixture than necessary.
    David Teitelbaum

  5. #55
    Senior Member
    Join Date:  May 2011

    Location:  Houston

    Posts:    597

    My VIN:    16113

    Club(s):   (SCDC) (DCUK)

    I'm trying to tune my car using a dwell meter but it either doesn't work or the diagnostic plug is not working. I'm reading about 8 volts in the plug but when I switch to the dwell setting nothing happens. I vaguely remember someone mentioning there is a place in the bulkhead where the dwell meter can be connected to check things. Does anyone remember where that is? Otherwise I may try connecting directly to the CO2 sensor. If that doesn't work then I may need to try a different dwell meter.
    Shannon

  6. #56
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,646

    My VIN:    03572

    Quote Originally Posted by lazabby View Post
    I'm trying to tune my car using a dwell meter but it either doesn't work or the diagnostic plug is not working. I'm reading about 8 volts in the plug but when I switch to the dwell setting nothing happens. I vaguely remember someone mentioning there is a place in the bulkhead where the dwell meter can be connected to check things. Does anyone remember where that is? Otherwise I may try connecting directly to the CO2 sensor. If that doesn't work then I may need to try a different dwell meter.
    One lead of the dwell meter goes to ground (engine block is fine) and the other lead can connect right on the frequency valve wire red/brown. The FV has a two pin connector (it may be three pin but only two wires) on the bulkhead. You test your reading by pressing the wide open throttle switch and the meter should read 54 degrees.
    Dave M vin 03572
    http://dm-eng.weebly.com/

Page 6 of 6 FirstFirst ... 4 5 6

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •