Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13

Thread: Electronic fused fan fail sales on hold

  1. #1
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    Electronic fused fan fail sales on hold

    I'm holding sales of my electronic fused fan fail unit. Using it with OEM fans that draw high start current can cause the "fuse" to trip. I have been prototyping new circuitry for a few months and now have a prototype unit I'm happy with. But one of the new IC's I'm using has not been released in production quantities. It is expected in 26 weeks. I'm using an alternate part in my prototype but it has less accuracy than the one not available yet.

    I have designed a new current sensor used to monitor each fan current. I was using a hall effect IC rated for 20 amps continuous and 100 amps for 100 ms. But I have had a few of those components fail with customer units. My new design uses a one watt 0.001 ohm resistor and an op-amp to give me current reading up to 50 amps and should be able to run continuous at 100 amps without damage.

    So I needed to be able to read more current and the software now does the following. I tested a 20 amp fuse in my car with the fan connector shorted and peak current was 120 amps for 41 ms then the fuse popped. A 30 amp fuse held for 134 ms before it popped.

    1) When a fan is turned on no trip current is checked for 40 ms.
    2) Then the fan trip current is set to 45 amps for 200 ms.
    3) Then the fan trip current is set to 40 amps for the next 400 ms.
    4) Then the fan trip current is set to 30 amps for the next 800 ms.
    5) Then the fan trip current is set to the final current of 20 amps.

    I chose those currents which should keep OEM fans (even older high current fans) from tripping the fuse. The whole point of fusing the fans is to prevent damage or fire to the wiring in the harness and I feel those short overload currents of the fan starting current will not overheat any wiring.

    Another added benefit to my new circuit is less current draw by the new current sensing which helps the unit running cooler.

    I also monitor the input voltage (power from the fan relay) and will shut off the fans if that voltage drops below 8.0 volts. If the voltage rises above 9.0 volts it will start up the fans with the same current trip setting as a normal power up. When the voltage has dropped to 8.0 volts the fan fail light will stay on continuous however the voltage driving the fan fail light will be that 8 volts or less..

    I still keep the flashing fan fail warning if either fan draws less than 4 amps or greater than 18 amps. The second fan turn on delay is now 2.44 seconds.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  2. #2
    Senior Member DavidProehl's Avatar
    Join Date:  May 2011

    Location:  Maple Grove, MN (Minneapolis)

    Posts:    1,158

    My VIN:    05457

    There is no concern or risk with using your old module with updated low draw fans correct? I've been very happy with your module, running it for close to 4 years now.
    David Proehl

  3. #3
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    Quote Originally Posted by DavidProehl View Post
    There is no concern or risk with using your old module with updated low draw fans correct? I've been very happy with your module, running it for close to 4 years now.
    No problems with low current fans. I'm still using the electronic fused unit in my car with Toby's fans. The fused unit never had the problem because the fuses don't react to fan starting current.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  4. #4
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    I went ahead and ordered new circuit boards which will arrive in about 4 weeks. I plan to make up 10 units and mesure the accuracy using the op-amps that are available now. I was just looking for the best accuracy but susspect these now available parts will work fine.

    FYI:
    Three parts affect the accuracy of my measurement of the fan currents. First is the current sense resistor which is a 0.001 ohm 1%. Then is the op-amp gain which is specified as 1.5% on the now available part and 1% on the part not released yet. Then is the reference voltage for my analog to digital converter which is typical at 0.4% but specified to be within 2%.

    There could also be some circuit board affects but those I can adjust for in software.

    I could also make a calibration routine in my software if I find it necessary.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  5. #5
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    While waiting for my new circuit boards, I set up a test using 20 amp ATC fuses to measure the time it took to pop at the following over loads.

    ; Fuse test, 20 amp fuse at 45 amps took 332 ms to pop
    ; Fuse test, 20 amp fuse at 40 amps took 470 ms to pop
    ; Fuse test, 20 amp fuse at 35 amps took 800 ms to pop
    ; Fuse test, 20 amp fuse at 30 amps took 9 seconds to pop

    My new fan fail will follow the overloading time down to 35 amps but after that, above 20 amps will "pop" my electronic fuse.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  6. #6
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    I was able to purchase the ICs I was waiting for from Texas instruments. Got my new circuit boards yesterday. Now I'm in the process of building up 10 units. But I had to order and inspection microscope to check my soldering on the little (SC70) op-amps.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  7. #7
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    Got the first board set done and the results look better than I expected. I was concerned with accuracy since my new circuit has a 50 amp full scale current reading. The typical component tolerances are so much better than using the maximum specifications. With my software using calculated values for the currents I got the following with the first unit.

    Low current flash on fan #1, 4.0 amps. No error on that one.
    Low current flash on fan #2, 4.0 amps. No error on that one.

    High current flash on fan #1, 18.3 amps. I wanted 18.0 amps.
    High current flash on fan #2, 18.2 amps. I wanted 18.0 amps.

    High current trip on fan #1, 20.4 amps. I wanted 20.0 amps.
    High current trip on fan #2, 20.3 amps. I wanted 20.0 amps.

    I'm waiting on my inspection microscope to finish up the other 9 board sets. I plan to average the readings on the 10 units to adjust the software for best current results.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  8. #8
    Senior Member
    Join Date:  May 2013

    Posts:    123

    I love work like this

    The whole fan circuit seems to depend on the Otterstat working tho. Failed Otterstat >> no fans, no matter how robust Bitsyncmaster's systems are.

    My Otterstat packed up a few weeks ago and I ended up boiling the coolant tank before I shut it off, even tho temp gauge was nowhere near the Red. A lot hinges on that $10 part

  9. #9
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    Quote Originally Posted by Horsebox View Post
    I love work like this

    The whole fan circuit seems to depend on the Otterstat working tho. Failed Otterstat >> no fans, no matter how robust Bitsyncmaster's systems are.

    My Otterstat packed up a few weeks ago and I ended up boiling the coolant tank before I shut it off, even tho temp gauge was nowhere near the Red. A lot hinges on that $10 part
    Yes the otterstat and it's wiring are critical. I need to do some changed to my engine harness and I was thinking of changing those two wires with new pins.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  10. #10
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,453

    My VIN:    03572

    Got my microscope and am very pleased with the quality for $400. After the kids played with it, I inspected my boards and found two solder connections on those very small op-amps needing rework.

    I tested four units and out of the 8 op-amps (two on each board) 5 were bad. So I installed two of the other manufactures op-amps I was using and those tested good and a little better accuracy then the "TI" parts. I have another 4 of the old ones and will replace the TI parts and test.

    After having the high failures I don't trust how long the TI parts will work even if they test good. It may be the parts are getting overheated when I solder them on but I solder the old ones on the same way and non have failed.

    My plan is to trash the TI parts and order the alternate parts.
    Dave M vin 03572
    http://dm-eng.weebly.com/

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •