Results 1 to 4 of 4

Thread: Check Your Full Throttle Enrichment Switch

  1. #1
    Senior Member nkemp's Avatar
    Join Date:  Jun 2011

    Location:  Buffalo MN

    Posts:    579

    My VIN:    897 5 spd,

    Check Your Full Throttle Enrichment Switch

    Heads up owners ... I checked my full throttle enrichment switch (Part#: 102785) and noticed that it was stuck closed (engaged). As such, it was always in the enriched mode. If it operates normally, you should be able to feel/hear it click. A meter will tell you if it is stuck closed as well. Also, be forewarned, Those bolts securing the switch to the plate have REALLY SMALL nuts on the bottom side and fall away to unknown destinations really easy. Also, to make reassembly easier, mark your alignment on the bracket by drawing a line on the bracket next to the switch.

    When I had it on the bench, the first thing to do is use a punch to push the pin the metal plate pivots on. Don't push all the way through or you risk losing the pin. Use a pliers on the last part to avoid losing the pin. If you lose the pin, a piece of paperclip cut and bent on both ends to hold in the hole will work until you decide to do something else about it. Remove the plate to get full access to the pushbutton.

    Next, using a magnifier, I noticed that the rubber boot around the plunger was cracked. Also, there seemed to be something else around the plunger (retainer?) and it seemed broken. First I sprayed a bit of MAF sensor cleaner on it and the button did not release/move. There was enough of the plunger to grab with pliers so that I could give it a gentle pull. The plunger will come out 1/4" and more, probably all the way out (I don't want to pull it out in fear of it not going back in properly). I think the reason that the plunger will come out is that when I pulled the plunger with the pliers it pulled the retainer out (I no longer see the part).

    So the likely failure mode was the broken retainer and sticky parts ( the switch now "clicks").

    At this point, I think I'll add a dab of heavy grease (high temp brake grease) to the plunger area to keep water and dust out. Not the best alternative since it may gum it up and/or run out when hot.

    Almost any normally open microswitch will work but, as is so often the case, the problem is mounting and alignment. As such, my goal is to reuse the switch ( replacements are $60'ish plus SH&H... and microswitches can be had for less than $5 delivered). I'll look around to see what I can find.

    SUMMARY:
    - You may not notice this unless you physically check the switch
    - The parts are getting old and deterioration may cause the plunger to stick closed
    - A little putzing on it can get it operational again, but repair of the failed boot and retainer is unlikely
    - A little grease on it if it has failed or not may help. It may help keep the grit out. But it may also gum it up a bit and run out under high temps
    - Worst case is to pull the connector until another fix is implemented . This stops continuous full enrichment but also eliminates full throttle enrichment
    This picture shows the plunger in. You can also see the cracked boot. IMG_7130.jpg
    Here the plunger is up a bitIMG_7131.jpg
    Sorry about the blurry photos.
    Nick
    - No matter how many people believe in a dumb idea ... it is still a dumb idea!
    - Some cars look fast. Some cars look faster than time!
    - The question is not "where did the time go" but rather "where to go in time".

  2. #2
    '82 T3 Turbo FABombjoy's Avatar
    Join Date:  May 2011

    Location:  Lansing, MI

    Posts:    548

    My VIN:    10270

    Overly tight mounting screws can do this as well. It'll be fine until you go WOT and then it can stick closed. I learned that the hard way!
    Luke S :: 10270 :: 1982 Grey 5-Speed :: Single T3 .60/.48 Watercooled :: Borla Exhaust :: MSD Ignition :: MS3X EFI :: DevilsOwn Methanol Injection

    Console5.com - Game console parts, kits, games and more. [shop] [wiki] [RSS] [f] [t]

  3. #3
    Senior Member
    Join Date:  May 2013

    Posts:    124

    Great post!

    I've had both metal plungers out of mine (auto) and it was no drama. My boot looked the same as yours too. I was just going to replace both switches until I saw how much they cost.

    I found that if you tightened the main bolts too tight then the switches would remain jammed ON.

  4. #4
    '82 T3 Turbo FABombjoy's Avatar
    Join Date:  May 2011

    Location:  Lansing, MI

    Posts:    548

    My VIN:    10270

    And in lieu of a mechanical switch, has anyone switched to a Hobbs vacuum switch? I purchased one set for 2Hg but then I tore out Kjet before testing it.
    Luke S :: 10270 :: 1982 Grey 5-Speed :: Single T3 .60/.48 Watercooled :: Borla Exhaust :: MSD Ignition :: MS3X EFI :: DevilsOwn Methanol Injection

    Console5.com - Game console parts, kits, games and more. [shop] [wiki] [RSS] [f] [t]

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •