Results 1 to 5 of 5

Thread: Fuel gauge flickering

  1. #1
    Senior Member
    Join Date:  Jun 2012

    Location:  Bay Area, CA

    Posts:    193

    Fuel gauge flickering

    I recently replaced the fuel sender seal.
    Everything seams to be working fine with the fuel sender (OEM one), however I noticed the fuel gauge is flickering a little. To be more specific I only noticed it when the tank is almost empty and the light goes on.
    Any advice on how to troubleshoot it?


    Sent from my iPhone using Tapatalk

  2. #2
    Delorean Guru
    Join Date:  May 2011

    Location:  Northern NJ

    Posts:    6,245

    My VIN:    10757

    Club(s):   (DMA)

    Quote Originally Posted by mburshtain View Post
    I recently replaced the fuel sender seal.
    Everything seams to be working fine with the fuel sender (OEM one), however I noticed the fuel gauge is flickering a little. To be more specific I only noticed it when the tank is almost empty and the light goes on.
    Any advice on how to troubleshoot it?


    Sent from my iPhone using Tapatalk
    The fine wires and the contacts on the float can corrode from the stuff they call gasoline nowadays. The cure is to clean it all up with some fine sandpaper. That means removing the sender unit and taking it apart carefully.
    David Teitelbaum

  3. #3
    Senior Member
    Join Date:  Jun 2012

    Location:  Bay Area, CA

    Posts:    193

    Fuel gauge flickering

    Quote Originally Posted by David T View Post
    The fine wires and the contacts on the float can corrode from the stuff they call gasoline nowadays. The cure is to clean it all up with some fine sandpaper. That means removing the sender unit and taking it apart carefully.
    Thanks David, so that's a known issue with a corroded sender and not an issue with the fuel gauge?


    Sent from my iPhone using Tapatalk
    Last edited by mburshtain; 04-15-2017 at 11:14 PM.

  4. #4
    Delorean Guru
    Join Date:  May 2011

    Location:  Northern NJ

    Posts:    6,245

    My VIN:    10757

    Club(s):   (DMA)

    Quote Originally Posted by mburshtain View Post
    Thanks David, so that's a known issue with a corroded sender and not an issue with the fuel gauge?


    Sent from my iPhone using Tapatalk
    If you haven't disturbed the binnacle, most of the problems with the fuel gauge occur in the sending unit.
    David Teitelbaum

  5. #5
    Senior Member
    Join Date:  Jun 2012

    Location:  Bay Area, CA

    Posts:    193

    Yeah, it was the fuel sender

    I cleaned the fuel sending unit with WD40 and fine sanding paper.
    Fuel gauge looks okay now, no more flicking.

    Thanks guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •