Page 4 of 6 FirstFirst ... 2 3 4 5 6 LastLast
Results 31 to 40 of 59

Thread: No Power to fuse 7 in fuse box for fuel pump while key is on

  1. #31
    Senior Member
    Join Date:  Jul 2012

    Location:  Thousand Oaks, CA

    Posts:    134

    My VIN:    16563

    Quote Originally Posted by DMC5180 View Post
    It is inside but should not be in an area you would disturb with carpet removal. The inertia switch breaks the Ground path if tripped. You still need to get to the fuel pump to check things out.


    Sent from my iPhone using Tapatalk
    Ok. Ill get that done tomorrow morning. Thank you and stay tuned.

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    1983 Delorean-auto, black/gray int. 38k miles

  2. #32
    Senior Member DMC5180's Avatar
    Join Date:  May 2011

    Location:  Reedsburg, WI

    Posts:    3,238

    My VIN:    5180

    Club(s):   (DMWC) (DCUK)

    Quote Originally Posted by artisticent View Post
    Ok. Ill get that done tomorrow morning. Thank you and stay tuned.

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    Will do.


    Sent from my iPhone using Tapatalk
    DENNIS

    VIN 5180, Frame 3652, STAGE I, DM-eng Solid State Solutions (RPM Rly, Dm.Lt.Mod., Fan Fail Mod. , FAN Rly, HS.Rly) , HID sealed beam style headlights, SPAX user since 2009, Eibach springs, Mid-State Club Adj. Rear LCA's, DPNW poly-sway bar kit, DMCEU LCA Stabilizer link kit, DMCMW Illuminated door sills, Aussie Illuminated SS Shifter plate, GENUINE MOMO EVO Steering wheel, DELOREANA Extended View Side Mirrors w/ Heaters, DELOREANA LED Door Lights.

  3. #33
    Senior Member
    Join Date:  Jul 2015

    Location:  Tacoma, Wa

    Posts:    1,147

    My VIN:    4877

    Good luck
    Rob Depew
    Tacoma, Wa
    '81 DeLorean 4877 Grey, Auto, 4 wheels
    Now Accepting Donations to get her back on the road

  4. #34
    Senior Member
    Join Date:  Jul 2012

    Location:  Thousand Oaks, CA

    Posts:    134

    My VIN:    16563

    Quote Originally Posted by Lwanmtr View Post
    Good luck
    Thanks guys. I'm on a good path thanks to you guys

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    1983 Delorean-auto, black/gray int. 38k miles

  5. #35
    Senior Member
    Join Date:  Jul 2012

    Location:  Thousand Oaks, CA

    Posts:    134

    My VIN:    16563

    I disconnected the plug but this is the fuel pump connector?

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    1983 Delorean-auto, black/gray int. 38k miles

  6. #36
    Senior Member
    Join Date:  Jul 2015

    Location:  Tacoma, Wa

    Posts:    1,147

    My VIN:    4877

    Yep, thats the fuel pump
    Rob Depew
    Tacoma, Wa
    '81 DeLorean 4877 Grey, Auto, 4 wheels
    Now Accepting Donations to get her back on the road

  7. #37
    Senior Member DMC5180's Avatar
    Join Date:  May 2011

    Location:  Reedsburg, WI

    Posts:    3,238

    My VIN:    5180

    Club(s):   (DMWC) (DCUK)

    Now probe the dirty connector hiding under the lip of the opening.


    Sent from my iPhone using Tapatalk
    DENNIS

    VIN 5180, Frame 3652, STAGE I, DM-eng Solid State Solutions (RPM Rly, Dm.Lt.Mod., Fan Fail Mod. , FAN Rly, HS.Rly) , HID sealed beam style headlights, SPAX user since 2009, Eibach springs, Mid-State Club Adj. Rear LCA's, DPNW poly-sway bar kit, DMCEU LCA Stabilizer link kit, DMCMW Illuminated door sills, Aussie Illuminated SS Shifter plate, GENUINE MOMO EVO Steering wheel, DELOREANA Extended View Side Mirrors w/ Heaters, DELOREANA LED Door Lights.

  8. #38
    Senior Member
    Join Date:  Jul 2012

    Location:  Thousand Oaks, CA

    Posts:    134

    My VIN:    16563

    Quote Originally Posted by Lwanmtr View Post
    Yep, thats the fuel pump
    I get no power when the key is on but when I turn the key to crank, my volt meter reads between 9.8 and 11.5.

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    1983 Delorean-auto, black/gray int. 38k miles

  9. #39
    Senior Member
    Join Date:  Jul 2012

    Location:  Thousand Oaks, CA

    Posts:    134

    My VIN:    16563

    Quote Originally Posted by artisticent View Post
    I get no power when the key is on but when I turn the key to crank, my volt meter reads between 9.8 and 11.5.

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    I was sure i used to hear the fuel pump with key on but i guess i was mistaken if no power gets to it unless I'm cranking the engine

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    1983 Delorean-auto, black/gray int. 38k miles

  10. #40
    Delorean Guru
    Join Date:  May 2011

    Location:  Northern NJ

    Posts:    5,801

    My VIN:    10757

    Club(s):   (DMA)

    Quote Originally Posted by artisticent View Post
    I was sure i used to hear the fuel pump with key on but i guess i was mistaken if no power gets to it unless I'm cranking the engine

    Sent from my SAMSUNG-SM-N920A using Tapatalk
    Now that you are at the connector to the fuel pump, check for power AND ground there. You MUST have BOTH for the pump to run. Depending on which one is not present (power or ground) will determine your next steps. To get power you can jumper the RPM relay for testing purposes.
    David Teitelbaum

Page 4 of 6 FirstFirst ... 2 3 4 5 6 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •