Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14

Thread: 10 year ownership. Time to do a major going over. What all would you do? LONG POST!!!

  1. #11
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    257

    All very good responses and I appreciate it. My lower back is ruined so getting her up and sliding around underneath is something I can rarely do. Unlike most my driving season are spring,fall and winter. This car is NOT a summer car at least not SC summers. I think I found the tires and trying to decide if I want to replace the stock exhaust. I have learned especially with this car that if it's working "leave it alone." A simple job turns into broken bolts and next day air.
    "Owning a Delorean is like frying bacon naked."

  2. #12
    Administrator Ron's Avatar
    Join Date:  Jun 2011

    Location:  North GA

    Posts:    4,374

    Club(s):   (SEDOC) (DCUK)

    Quote Originally Posted by JIMJAM View Post
    You should know. How many countless hours have we spent. Vitons, 3 fuel dist, 2 of which were bad. All new f injectors, basically everything gas touched. Bottom line is the car HATES summer.

    I am sure I got one of your rpm relays but that was very early on. I have no clue what version I have or what you have now. Guess I need to check and also don;t remember a jumper.
    Quote Originally Posted by Bitsyncmaster View Post
    I do remember you have my RPM relay. All versions had the "HOT START FIX". Just pop the case off it an look if the jumper is on the end terminal or moved in one pin.
    I remember seeing a stockpile of RMP relays, but not one of Daves...

    I'm guessing one of those and ditching its battery shutoff conglomeration would make it LOVE you instead...

  3. #13
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    257

    You are the magician.... You took off my battery shutoff remember? It proved to be more of a problem and source of issue than nit was worth. Now its wired directly and I just hook it up to a trickle charger every few days.
    After driving it for a while I noticed it running a little rough after starting but clearing up and its not even hot out yet. Probably the usual suspects.. A leaky injector, a O ring wearing down, chipped....
    Only time it had a classic hot start refuse to start was late last summer 90+, parked on blacktop after running almost 2 hrs. Took the air cleaner off, a hit of starter fluid and it fired right up.
    Find my tires yet? Found the receipt.. Bought in 09 and probably 5-7 thousand miles on em.
    Last edited by JIMJAM; 02-03-2018 at 08:13 PM.
    "Owning a Delorean is like frying bacon naked."

  4. #14
    Administrator Ron's Avatar
    Join Date:  Jun 2011

    Location:  North GA

    Posts:    4,374

    Club(s):   (SEDOC) (DCUK)

    Too many moons ago, but I want to say no, because I remember there was something you were going to pick up involving the switch when you left. Maybe a cable end and a standard length side terminal bolt...Anyway, it sounds like all you need now is to get Dave to play Cupid!

    I already PMed you on the tires....
    (Wrong thread for that anyway ;-)

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •