Page 2 of 2 FirstFirst 1 2
Results 11 to 13 of 13

Thread: Terrible customer service rant thread

  1. #11
    Senior Member
    Join Date:  Jul 2015

    Location:  Tacoma, Wa

    Posts:    1,827

    My VIN:    4877

    If you give me the details on your honda i can give 'em a call and see if they have any in their yard.
    Rob Depew
    Tacoma, Wa
    '81 DeLorean 4877 Grey, Auto, 4 wheels
    The Ressurection of 4877......
    Now Accepting Donations to get her back on the road

  2. #12
    Mr. Pickles-mobile Shep's Avatar
    Join Date:  Sep 2011

    Location:  Middleburg Heights, OH

    Posts:    1,933

    My VIN:    559

    Quote Originally Posted by Lwanmtr View Post
    If you give me the details on your honda i can give 'em a call and see if they have any in their yard.
    Why? Did the online search feature break? It's right on their homepage: https://www.pullapart.com/

    Cleveland's right around the corner, W 130th is a VERY familiar area to me, I've been there a few times.
    Proud owner and operator of



    Main site (OUTDATED) -- Product update thread!

  3. #13
    Stupid Newbie DaraSue's Avatar
    Join Date:  Jul 2016

    Location:  The LC

    Posts:    767

    My VIN:    10907

    A postscript to this story - a yard near me got an 86 in with the same engine as mine, so I went and grabbed the valve cover for $11. Suck it, Phil's Salvage! (I didn't even really need it but it was in decent shape and I figured I should get it just in case.)

    Now if only the front fenders had been intact...

Page 2 of 2 FirstFirst 1 2

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •