FRAMING JOHN DELOREAN - AT THEATERS THIS WEEKEND & ON VOD www.framingjohndeloreanfilm.com
Page 2 of 2 FirstFirst 1 2
Results 11 to 14 of 14

Thread: No Start-Embarrassment ***Split From What have you done to your DeLorean today?***

  1. #11
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    7,452

    My VIN:    03572

    Quote Originally Posted by SS Spoiler View Post
    Went to Heritage Days Parade in Columbia Falls [17 mi]
    ran fine all the way. Shut it off half an hour before the
    parade, tried a restart....crank, crank nothing. Did smell
    gas so I waited for the parade to start with the gas pedal
    floored, thinking it would dry out. Gave it one last try and
    it roared to life, got in line did parade drove home. Its
    acting like a fuel problem. Besides stalling at lights [bump
    starts fine] it also occasionally idle drops to 500 rpm and
    doesn't respond to the throttle, unless I shut it off and
    quick restart and acts normally.
    Side note: the ignition switch will shut off engine, but
    dash lights stay on. Have to use Master Battery kill
    switch or battery goes flat. It's rapidly declining in
    reliability.....more ideas?
    You need to fix that "dash lights stay on" problem first and it may fix other problems. If you don't know how to read a schematic and use a voltmeter maybe someone close can help you.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  2. #12
    Administrator Ron's Avatar
    Join Date:  Jun 2011

    Location:  North GA

    Posts:    4,941

    Club(s):   (SEDOC) (DCUK)

    +1

    Sounds like more than one circuit to me.
    (Relay hanging?)

    Do the marker, tail, or other lights stay on when the dash (?instrument & panel?) lights stay on?

  3. #13
    Senior Member
    Join Date:  May 2011

    Location:  Burnsville MN-Moving to Kalispell MT. in June 20111

    Posts:    825

    My VIN:    2691

    hmmm

    Pulled all the fuses with battery master on
    Didn't shut off dash battery light [the only one
    lit up]. Will check starter and alternator wires
    to see if anything is touching.

  4. #14
    Administrator Ron's Avatar
    Join Date:  Jun 2011

    Location:  North GA

    Posts:    4,941

    Club(s):   (SEDOC) (DCUK)

    Try unplugging the NY (Brown/Yellow) wire at the alternator first.

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •