FRAMING JOHN DELOREAN - ON VOD www.framingjohndeloreanfilm.com
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15

Thread: Delorean go fuse box

  1. #11
    Junior Member AZ-D's Avatar
    Join Date:  Jul 2018

    Location:  Ahwatukee,AZ

    Posts:    20

    My VIN:    Previous owner of 2646. I have no idea where it is now.

    Quote Originally Posted by Bitsyncmaster View Post
    You would need the key turned all the way on to get power to all the fuse block. Don't know why you need to test what is not working before replacing the fuse block. I guess in a rare failure that would save you a terminal if you had to replace a broken wire.
    I don't want to wonder if something does not work cause I did something wrong or if it didn't work to begin with.

    Quote Originally Posted by Ron View Post
    +1 Dave.
    The only other reason I can think of is so you know that you you caused a new problem during installation...

    The door light fuse (#12) should always be hot (12V+ both sides) regardless of the key position. So with the key on or off, when you open either door, its lights should come on. And the interior lights may come on, depending on what mode their individual switch is set to (always on/always off/off after delay). If the door lights only come on when you pull and reinstall the same fuse, it is probably a bad connection at the fuse's socket (terminal pushed down in the socket, dirty connection, broke wire on either side of the fuse, and rarely a flaky fuse). It would be odd if it didn't do this intermittently....
    How do the interior lights act?
    It is probably just the connection cause they turned on when I hook the battery up no issue this time. Interior lights work as well.

  2. #12
    Junior Member AZ-D's Avatar
    Join Date:  Jul 2018

    Location:  Ahwatukee,AZ

    Posts:    20

    My VIN:    Previous owner of 2646. I have no idea where it is now.

    I tested all the fuses, I have power to all of them except #2, 8, 14, and whatever the inline fuse pictured is with the 2 blue/white wires. I am going to assume its most likely #15? I also moved working fuses to those spots and still didn't get power.

    Where should I start to trouble shoot the non working fuses?

    fuse box.jpg

  3. #13
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    7,638

    My VIN:    03572

    Quote Originally Posted by AZ-D View Post
    I tested all the fuses, I have power to all of them except #2, 8, 14, and whatever the inline fuse pictured is with the 2 blue/white wires. I am going to assume its most likely #15? I also moved working fuses to those spots and still didn't get power.

    Where should I start to trouble shoot the non working fuses?

    fuse box.jpg
    Turn your lights on and you should get power on 2, 8, and 14 if you have low beam selected.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  4. #14
    Senior Member DMC5180's Avatar
    Join Date:  May 2011

    Location:  Reedsburg, WI

    Posts:    3,902

    My VIN:    5180

    Club(s):   (DMWC) (DCUK)

    Delorean go fuse box

    Quote Originally Posted by AZ-D View Post
    I tested all the fuses, I have power to all of them except #2, 8, 14, and whatever the inline fuse pictured is with the 2 blue/white wires. I am going to assume its most likely #15? I also moved working fuses to those spots and still didn't get power.

    Where should I start to trouble shoot the non working fuses?

    fuse box.jpg
    The floating fuse with 2 blue/white wires is fuse 15 (high beam). The other floating fuse is fuse 10 (A/C mode switch). Your missing fuse 13 is (Auto transmission only). It has power going to it but doesn’t power anything down stream. Fuse 18 (brake lights) is not used (usually Empty) but I see wire terminals in your fuse box so you might need a 10 amp fuse there.
    Last edited by DMC5180; 12-08-2019 at 01:06 AM.
    DENNIS

    VIN 5180, Frame 3652, STAGE II​, DM-eng Solid State Solutions (RPM Rly, Dm.Lt.Mod., Fan Fail Mod. , FAN Rly, HS.Rly) , HID headlights, SPAX user since 2009, Eibach springs, M Adj. Rear LCA's, DPNW poly-sway bar kit, DMCEU LCA Stabilizer link kit, DMCMW Illuminated door sills, Aussie Illuminated SS Shifter plate, REAL MOMO EVO Steering wheel, DELOREANA Extended View Side Mirrors w/ Heaters, DELOREANA LED Door Lights.

  5. #15
    Junior Member AZ-D's Avatar
    Join Date:  Jul 2018

    Location:  Ahwatukee,AZ

    Posts:    20

    My VIN:    Previous owner of 2646. I have no idea where it is now.

    Quote Originally Posted by DMC5180 View Post
    I see wire terminals in your fuse box so you might need a 10 amp fuse there.
    Where are you referring to here?

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •