FRAMING JOHN DELOREAN - ON VOD www.framingjohndeloreanfilm.com
Page 2 of 2 FirstFirst 1 2
Results 11 to 15 of 15

Thread: Drivers front and rear indicator lights not working, but hazards do.

  1. #11
    Senior Member
    Join Date:  Jul 2011

    Posts:    201

    My VIN:    04512

    Thanks for the input guys. I'll check on those things. I know for the fronts I swapped the new bulbs around and both bulbs worked on the passenger side without issues. I even replaced the indicator harness with a known good harness and still no running light from the drivers side.

    For the rear passenger taillight. I just turned on the turn signal and both flash but they do so quickly. Leading me to believe I have some connectors in the back to clean up better. I'll let you know what I come up with.

    Thanks again.
    Erik
    04512 since '99

  2. #12
    Senior Member
    Join Date:  Dec 2016

    Posts:    340

    Quote Originally Posted by dmcerik View Post
    Thanks for the input guys. I'll check on those things. I know for the fronts I swapped the new bulbs around and both bulbs worked on the passenger side without issues. I even replaced the indicator harness with a known good harness and still no running light from the drivers side.

    For the rear passenger taillight. I just turned on the turn signal and both flash but they do so quickly. Leading me to believe I have some connectors in the back to clean up better. I'll let you know what I come up with.

    Thanks again.
    A quick flash (hyperflash) turn signal can happen when LED bulbs are replaced but the flasher relay is still original. The original flasher relay is not compatible with most LED bulbs. Replace the flasher relay with an LED compatible one.

    Ron

  3. #13
    Senior Member
    Join Date:  Jul 2011

    Posts:    201

    My VIN:    04512

    The flasher relay is LED compatible and came with the kit supplied by the Delorean vendor.
    Erik
    04512 since '99

  4. #14
    My frame has two coats of wax Michael's Avatar
    Join Date:  May 2011

    Posts:    4,318

    My VIN:    I respect my vin enough not to whore it out among the masses.

    Quote Originally Posted by dmcerik View Post
    The flasher relay is LED compatible and came with the kit supplied by the Delorean vendor.
    I think you need to revert back to the old relay and bulbs just to get the problem sorted out. You may be working against yourself with the LED kit added on.

    Once the main issue is resolved, then put the LED kit back in place.

  5. #15
    Administrator Ron's Avatar
    Join Date:  Jun 2011

    Location:  North GA

    Posts:    5,563

    Club(s):   (SEDOC) (DCUK)

    +1!

Page 2 of 2 FirstFirst 1 2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •