Page 3 of 7 FirstFirst 1 2 3 4 5 ... LastLast
Results 21 to 30 of 68

Thread: My Delorean stops running

  1. #21
    Member
    Join Date:  Feb 2013

    Posts:    54

    My VIN:    3095

    Club(s):   (DCF)

    Thanx Guys - I unplugged what I "think" was the 02 scensor according to Delorean03's directions, and IT WORKED. I started my car, let it run - unplugged this connection and it stayed running 30 min. I drove it up & back my street - no problems. I sure hope this was the fix. Should I worry about not having this connection or think about replacing it ?

    Morpheus - It would just cut off. That is why I was thinking fuel - pump, filter, etc. But I followed what was suggested earlier and it ~seems~ to have worked.

    Thank You Everyone for your help ! Know owning a Delorean, this wont be the last time I need advise. I want to learn everything about my car, and you guys are a fantastic help.

  2. #22
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,685

    My VIN:    03572

    Many people run without the lambda system but if you need to pass emissions or just want the best MPG, you should fix what is broken with it. You should first test with a dwell meter if the FV is running. It should be 45 to 50 degrees or 50 to 60% if you your meter is reading duty cycle. You could also guess it works by hearing or feeling it buzzing. If that is working my guess would be the FV is hosed wrong or defective.

    Can you post a photo of your hoses of the FV and where they bolt to on the FD?

    The FV should still be buzzing with the O2 disconnected. Maybe your mixture is just way off.
    Last edited by Bitsyncmaster; 02-18-2013 at 07:13 PM.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  3. #23
    DMC Midwest - 815.459.6439 DMCMW Dave's Avatar
    Join Date:  May 2011

    Location:  Crystal Lake IL

    Posts:    5,027

    My VIN:    05429

    Quote Originally Posted by DeLorean03 View Post
    Thank you Dave, I will be installing a rubber grommet now as part of my "holy crap this water pump replacement just got more interesting" winter downtime .
    It shouldn't need one. The grommet is part of the connector. From inside the car just push it back in place.
    Dave S
    DMC Midwest - retired but helping
    dswingle@DeLorean.com

  4. #24
    Member
    Join Date:  Feb 2013

    Posts:    54

    My VIN:    3095

    Club(s):   (DCF)

    Dave - I'm not understanding - FV ? FD ?

  5. #25
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,685

    My VIN:    03572

    Quote Originally Posted by Iceguy View Post
    Dave - I'm not understanding - FV ? FD ?
    Sorry.

    FV = Frequency Valve. on passenger side valve cover.

    FD = Fuel Distributor. The round black thing with all your fuel hoses going to it.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  6. #26
    Member
    Join Date:  Feb 2013

    Posts:    54

    My VIN:    3095

    Club(s):   (DCF)


  7. #27
    Senior Member Bitsyncmaster's Avatar
    Join Date:  May 2011

    Location:  Leonardtown, MD

    Posts:    6,685

    My VIN:    03572

    I was looking for the drawing of the fuel hose routing but could not find it. It was done very nicely on the old forum. Your hoses look pretty clean and probably are attached correctly.

    When you get time, pull the air cleaner off and you will see the FV. If you touch the FV with a wooden dowel or a large screw driver then touch your ear with the end of dowel (use your hand as a pad for you ear). It works just like a stethoscope. You should hear the FV buzzing when your engine is running. That trick works good to find other problems with engines like a bad bearing.
    Dave M vin 03572
    http://dm-eng.weebly.com/

  8. #28
    Senior Member jmpdmc's Avatar
    Join Date:  May 2011

    Location:  Cranberry Twp., PA

    Posts:    103

    My VIN:    01678

    Fuel Hose Diagram this thread post #3: http://dmctalk.org/showthread.php?352-K-Jetronic-System


    Jeff

  9. #29
    Member
    Join Date:  Feb 2013

    Posts:    54

    My VIN:    3095

    Club(s):   (DCF)

    The hoses were redone by the previous owner, I found the bill in the glovebox. I will try the trick with the FV tomorrow.

  10. #30
    Member
    Join Date:  Feb 2013

    Posts:    54

    My VIN:    3095

    Club(s):   (DCF)

    Well Im back to the begining again. This is the wire I disconnected yesterday. Today I'm back to running 2 - 4 minutes.
    Attached Images

Page 3 of 7 FirstFirst 1 2 3 4 5 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •