Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11

Thread: Im down for maintenance as of 11JUL

  1. #1
    Junior Member
    Join Date:  May 2011

    Posts:    14

    Im down for maintenance as of 11JUL

    Looks like my "D" has sprug a tranny leak. looks like I will be out for a couple of weeks while I tear into it. And she was running so well too....

    ~Josh

  2. #2
    Member
    Join Date:  May 2011

    Location:  Bellevue, WA.

    Posts:    94

    My VIN:    6292 since Oct 1982 and THE DELOREAN TRAILER

    Club(s):   (PNDC)

    Will you be up and running for the Whidbey Island Naval Air Station car show on July 30th? Will you be staying overnight? Please keep us up to date re your status.
    Arnie

  3. #3
    Junior Member
    Join Date:  May 2011

    Posts:    14

    Tranny input shaft faulty

    I got the transmission out of the car today; looks like the input shaft seal has been leaking for a while. I still need a couple of parts (possibly anew clutch, but need to inspect). I am taking the chance to upgrade the tranny while its out. The plan is to have the transmission apart by tomorrow, rebuilt during the week, and reinstalled next weekend. If all goes well I should be good for CONA.

  4. #4
    Junior Member
    Join Date:  May 2011

    Posts:    14

    About 80% sure I'll make it to CONA

    Got the Tranny rebuilt, rear main put in, and CV axles repacked. Doing a leak down test on the gaskets for the transmission. If it holds its insides inside, I will put in the car in the morning. Just in time to head north.

  5. #5
    Junior Member
    Join Date:  May 2011

    Posts:    14

    Update 3

    Transmission in.Taking break before attaching all the shift cables, mounts, CV axles and Starter.

    So far so good.

  6. #6
    Not dead yet, also Admin. sean's Avatar
    Join Date:  May 2011

    Location:  Dahlonega GA

    Posts:    2,467

    Club(s):   (SEDOC) (DCUK)

    Nice turnaround time.
    eBay selling at it's best I can tell you stock Delorians and quite a bit of slugs so the Turbo is a super nice up-grade.
    K-Jet: Causing electrical issues since November 5th 1955

  7. #7
    Junior Member
    Join Date:  May 2011

    Posts:    14

    it lives....

    @Sean - would have been faster if some parts didn't come broken from DMC, plus i jacked up the rear main and had to ordera new one.

    Just drove it up to bellevue. No leaks and running strong. The delorean gods must be smiling. Ill see you guys in the morning.

  8. #8
    Not dead yet, also Admin. sean's Avatar
    Join Date:  May 2011

    Location:  Dahlonega GA

    Posts:    2,467

    Club(s):   (SEDOC) (DCUK)

    Quote Originally Posted by jjdaily View Post
    @Sean - would have been faster if some parts didn't come broken from DMC, plus i jacked up the rear main and had to ordera new one.

    Just drove it up to bellevue. No leaks and running strong. The delorean gods must be smiling. Ill see you guys in the morning.
    Did you jack the seal up while replacing it or during the transmission removal?
    eBay selling at it's best I can tell you stock Delorians and quite a bit of slugs so the Turbo is a super nice up-grade.
    K-Jet: Causing electrical issues since November 5th 1955

  9. #9
    Junior Member
    Join Date:  May 2011

    Posts:    14

    I messed up the seal trying to put it in. it went in sideways and had to be damaged to remove it. the easiest way to do it is to remove the rear main housing, put the rearmain in when its off, and use a new seal on the housing.

    everyting else was fine. did a 200 mile drie and all is good.

  10. #10
    Not dead yet, also Admin. sean's Avatar
    Join Date:  May 2011

    Location:  Dahlonega GA

    Posts:    2,467

    Club(s):   (SEDOC) (DCUK)

    Yeah, removing that housing helps a lot, just got to make sure to trim that paper gasket correctly and seal i up good then bring the housing bolts down evenly.
    eBay selling at it's best I can tell you stock Delorians and quite a bit of slugs so the Turbo is a super nice up-grade.
    K-Jet: Causing electrical issues since November 5th 1955

Page 1 of 2 1 2 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •