FRAMING JOHN DELOREAN - ON VOD www.framingjohndeloreanfilm.com
Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 27

Thread: Plug in to alternator replacement/fix ?

  1. #1
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    292

    My VIN:    1597

    Plug in to alternator replacement/fix ?

    Bat light was flashing during accel suspected loose belt. Tightened it and noticed bat light no loner on when key in ign and V was very low. Went to look at the belt again and saw a loose wire hanging tan/white iirc. All the wiring looks bad but this I suspect went into a plug that goes into one of John's alts. I dug out all the black silcon I could to expose a very old looking thingamajig and a broken off connector.

    I really did not stare at the loose wire so I do not know how many conductors are in it. The rough looking thingamajig that I suspect the wire broke off of looks like its just one.

    So questions are can and where can I find that plug that goes into the alternator and b, should I just resolder the wire back to it and refill it.

    Btw- I have always had wonky alt issues,voltage fluctuations etc so I just assume replace it. Any help,advice welcomed and Thanks ahead of time. Jim
    Attached Images
    "Owning a Delorean is like frying bacon naked."

  2. #2
    EFI'd dn010's Avatar
    Join Date:  Jul 2011

    Location:  Florida: Pinellas County

    Posts:    2,054

    My VIN:    5003 Never placed Concourse

    Club(s):   (DCF)

    Yep, happened to me too. The wire broke down in the silicone, there is a resister or similar component he solders down in there. I had to pay up another $13 or $15 for another plug....
    -----Dan B.

  3. #3
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    292

    My VIN:    1597

    Is it just one wire? I could easily,well Delorean easy, resolder the wire to it and fill it back in. But if its 2 or more wires and I have no clue what goes to what then I will cough up the money.
    "Owning a Delorean is like frying bacon naked."

  4. #4
    DMC Midwest - 815.459.6439 DMCMW Dave's Avatar
    Join Date:  May 2011

    Location:  Taylors SC

    Posts:    5,271

    My VIN:    (former)05429

    Club(s):   (DMWC) (DCUK)

    You only need the one wire, the replacement you buy will have all 4. Just cut the rest off, don't worry about the resistor mod.

    Universal GM alternator plug, Autozone/Oreilly/NAPA will have it.
    Dave S
    DMC Midwest - retired but helping
    dswingle@DeLorean.com

  5. #5
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    292

    My VIN:    1597

    Smile

    Hey Dave long time. So just solder the wire back to where it broke off/refill?
    The good ol fixing one problem leads to another. I did my best by myself to tighten the belt. Let me get it back the way it was and try again. Least I hope its a loose belt. I have noticed the voltage readout being a little low. Also the bat is showing less than 11 so it has not been charging.
    This is one of those sealed expensive batteries and I have never had to trickle charge it or ran it down.
    "Owning a Delorean is like frying bacon naked."

  6. #6
    EFI'd dn010's Avatar
    Join Date:  Jul 2011

    Location:  Florida: Pinellas County

    Posts:    2,054

    My VIN:    5003 Never placed Concourse

    Club(s):   (DCF)

    Yes just solder the wire back from where it broke. Unfortunately I didn't know about not needing any resistor, the leg broke off of mine so I couldn't solder- so I paid up. Once you're done fill it back up with RTV and plug it back in.

    As far as the belt, are you hearing noise when accelerating? I can tell you that all my D### alternators from specialT have chatter from what I'm guessing are the magnets inside, it squeals really loud and the voltage drops until the engine gets warm. When the noise happens the volts go down, when the noise is gone it charges. It isn't the belt, I've visually confirmed that and I've complained about this numerous times with no fix just replacements... Maybe you've got the same problem...
    Last edited by dn010; 04-21-2015 at 08:53 PM.
    -----Dan B.

  7. #7
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    292

    My VIN:    1597

    All of a sudden I noticed the v needle was not charging or straight across but slight discharging. Then I noticed it dipping into "oh crap" territory. I do not trust that gauge at all so I payed it no real panic level attention. Then on one of the rare times I have driven the car in rain I noticed last week the battery light flickering. Wet belt slipping no biggie. Yesterday after being dry for 3 days I could rev it up and it would come on and go off when I released the pedal. Ok,I am convinced slipping belt. Well I tried to tighten it and I then noticed the wire after starting the car and seeing a almost zero V charge and no bat light with the ign on. Thats when i noticed the broken wire.
    I have never just fixed one issue so there is no telling what I may run into. I am going to solder it back on,attempt to tighten the belt again and see what happens.

    I spent a small fortune with special T when I got the car but have not bought anything from him in 2 years. Are things about the same as they always were there? I have been out of the loop for a few years and have not kept up with whats been going on in the Delorean world.
    Last edited by JIMJAM; 04-21-2015 at 09:25 PM.
    "Owning a Delorean is like frying bacon naked."

  8. #8
    EFI'd dn010's Avatar
    Join Date:  Jul 2011

    Location:  Florida: Pinellas County

    Posts:    2,054

    My VIN:    5003 Never placed Concourse

    Club(s):   (DCF)

    I've ordered odds and ends from John in the past few months with no issues. I think it was cooling hoses and a rack boot kit.

    In order to confirm a slipping belt I actually stood there at the engine revving it by hand and saw the belt wasn't slipping with the noise. I seem to be odd man out with the issue so maybe my car has some kind of oddity in its charging system.

    Fix the wire, check your belt tension and give it a test run, see what happens.
    -----Dan B.

  9. #9
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    292

    My VIN:    1597

    Its been a loooong time but I originally had his super dooper high amp alternator that was defective. I see now where he suggest its for highway use If you have that one I would get rid of it. I just saw where dmc wants $700 plus for the original alts. I gave 2 of them away. One that the orig owner had as part of his old parts and the one that was still on it. First thing I did was get rid of the orig Duc alt and got one of johns. Gave away the other 2 relics rather than carry them back from Atlanta.
    The D is a electrical nightmare and I have pretty much well replaced everything on the car that either electricity flows though or gas does. Seriously. After 8-9 yrs i still have not gotten rid of all the bugs. The alt regardless of whats in there has always been flakey. Same with the ignition. I have never ran a battery down or been standed but seeing a discharge is like watching a high temp or oil light. It just bothers you like a thorn in your foot. I have all the mods but still with all the acc on, fans,high beams,AC etc, the V needle sags enough to make you get nervous. The further away from home or the darker it is the more it irks me.

    I have had 3 back surgeries and a 4th in the next 3 months. If I cannot tighten or replace a alt belt its time to sell the car. Its getting harder and harder to lay on the floor and even worse when these 30 minute jobs go on for 3 hours if not a week if you need parts.
    Last edited by JIMJAM; 04-21-2015 at 09:52 PM.
    "Owning a Delorean is like frying bacon naked."

  10. #10
    Senior Member
    Join Date:  Jun 2011

    Location:  Columbia SC

    Posts:    292

    My VIN:    1597

    BTW- I guess its a good time to ask what is this gizmo and what happens if it is bad or acting up? I have seen what happens when it is not hooked up. But what about if its going bad? I would rather not do this 2 or 3x which has usually been how things end up being done with this car.
    "Owning a Delorean is like frying bacon naked."

Page 1 of 3 1 2 3 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •