If after inserting (not attaching) pics in your posts you see something like [ATTACH] MyPic.jpg [/ATTACH] instead of a picture, try this:

Click "Settings" (upper right corner, next to "Log Out") => Scroll down to 3rd Menu on left, "My Settings" / My Account => Click "General Settings" => Scroll down to last section, "Miscellaneous Options" => Under "Message Editor Interface:", click the radio button for "Enhanced Interface - Full WYSIWYG Editing". Click "Save Changes".

Afterwards, double clicking the image will bring up a menu allowing you to select different sizes.